MIDI import weird?

Hi all - not sure what I've done here but I recorded a track in Cubasis( what was I thinking? ;) ) and I was using the lovely NeoSoulKeys fender rhodes sounds as an AUV. Anyway, immediately after recording the midi data I was like 'screw this, I want to work in Nanostudio' so I have attempted to export the MIDI data from Cubasis and import it into Nanostudio, which I thought would be a straightforward affair.

But - something super weird has happened. The 3-minute track in Cubasis becomes a 5-and-a-half-hours track in Nanostudio, and the notes are all stretched out and slooooooow. I've tried changing the tempo and including the option 'import tempo track/time sig track' - but neither of those made a difference. I tried exporting to iPad Files app and also exporting directly to 'Open in Nanostudio' from Cubasis - no luck. I even tried to select all the Midi notes in Cubasis and copy them, then to paste them in Nanostudio - couldn't get that to work (Paste option is greyed out). I've also tried Audioshare. Same trouble.

What the blazes is going on? IS my Midi corrupted? It still plays in Cubasis fine! I just don't want to work in there :p=);)B):)


  • update: it seems to be a Cubasis problem, I opened the MIDI file on my mac and it was weird there too :)
    So I still have this MIDI file I want to get out of Cubasis into Nanostudio - does anyone have a workaround? Maybe I can live-record the midi data from Cubasis playing while Nanostudio is recording, or something?

    Thanks in advance :)

  • Second update: I’ve managed to record (from Cubasis live playing) the midi data at the right speed into a NS2 track. But, it seems the end of all the notes isn’t getting recorded, and possibly also missing the sustain pedal midi data. That is a huge job to go through one note at a time....
    If anyone can help me solve this problem, that would be so much appreciated :-) thanks!

  • Second update (sorry for all the messages!) : I rebooted iPad, updated Cubasis and tried exporting the midi file again. It came out better so I imported it to NS2 and it is very close! All note starts and ends now good.
    My last and driving-me-mad problem still to solve is that the midi data which corresponds to the sustain pedal (it was a keyboard improvisation) has come in as automation data on “Knob 1”, which doesn’t want to activate the sustain pedal on the AUV of the neoSoul Keys..... I have tried going in to the MIDI settings (midi controller map) to try a few of the sustain pedal settings there (I know that the NeoSoulKeys uses CC64 for sustain pedal information), but nothing seems to make the midi track play the automation data as sustain pedal data.....It seems like the midi controller map is more about connecting external controllers and where to send those inputs, rather than a map for the track to send to the AUV instrument..... can anyone help? thanks!!!

    (Maybe I could copy and paste the sustain pedal data into a track lane and somehow make it ‘control’ the virtual sustain pedal on the AUV instrument? I’m not sure if this is possible or how I would do it)

  • me again :p I've come to the conclusion that there is something weird between NeoSoulKeys AUV and Nanostudio2 regarding the capture of sustain pedal MIDI.

    On Cubasis, the pedal data is recorded under CC64, and on playback it controls the sustain pedal of the AUV as expected. But if I record directly into NS2 using NeoSoulKeys, then the sustain pedal data doesn't seem to be recorded at all - instead, the notes are changed in length so that they hold until the sustain pedal is lifted. So the data recorded has all the notes, and it sounds sort-of the same, but it disrupts the possibility to edit notes and/or sustain pedal mistakes, since they are merged into 'longer notes' data.
    I have not found a way to 'send' the CC64 data (which is in my imported MIDI file) from NS2 to NeoSoulKeys for playback purposes, so my choice seems to be (1) no sustain pedal info, or (2) altered notes data (where all notes hold until the pedal is released). Neither of these actually sounds the same as when the MIDI file plays through Cubasis with the pedal data going via CC64.

    I'm still looking into a workaround so if anyone has a proposal do let me know! :)

    Otherwise I think I've reached the end of my investigations and I've basically created a whole thread by myself haha....

    Lesson for next time is: either record my MIDI data straight into NS2 ( but am concerned about the pedal data not being editable, to correct mistakes etc), or stay in Cubasis (yuck) for mixing it and editing it (yuck). Hehe. If anyone else has had a similar experience with sustain-pedal MIDI data problems I would be interested to hear if you found a workaround - thanks!

    Addendum: I've now tried recording two other different AUVs (Ravenscroft piano and MiniMoog Model D) in NS2, and for none of them will NS2 record the sustain pedal actions as editable data, in the way that Cubasis and Auria Pro do - in NS2 it just makes the notes-data hold long until the pedal is released - which does sound different, if you are playing repeated notes for example.....

    Is this a bug/oversight? I would expect the sustain pedal to send in independent MIDI controller data which I could then edit. ?

    Many thanks, and I still love NS2 more than all the others... ;)

Sign In or Register to comment.