Force sample rate

I use a USB audio interface with my NS setup. When I plug in the USB interface, the sample rate in NS2 changes from 44.1 to 48. This means my backing tracks in Multitrack Recorder don't play at the correct speed and pitch. I cannot find a way to change the sample rate setting in NS2 or iOS. Is it possible?

Comments

  • @BjørnFelle said:
    I use a USB audio interface with my NS setup. When I plug in the USB interface, the sample rate in NS2 changes from 44.1 to 48. This means my backing tracks in Multitrack Recorder don't play at the correct speed and pitch. I cannot find a way to change the sample rate setting in NS2 or iOS. Is it possible?

    This is an unfortunate design choice by Apple, there's nothing you can do to change it. But it sounds like Multitrack Recorder isn't responding to the change properly. You could try reporting it as a bug to the dev.

  • @Stiksi said:
    This is an unfortunate design choice by Apple, there's nothing you can do to change it. But it sounds like Multitrack Recorder isn't responding to the change properly. You could try reporting it as a bug to the dev.

    I suspected as much. I develop iOS apps too so am frequently coming up against their bullshit :/ yeah I think Multitrack Recorder isn't converting on the fly between sample rates. It knows that the sample rate is wrong, because if you disable host sync and play the audio directly from Multitrack Recorder, it will warn you that the sample rate is wrong. But it doesn't resample or whatever needs to be done to get it to play correctly. I'm currently in the process of recreating new live versions at 48khz which is taking ages but will solve the problem. Thanks dude, I will contact the devs of Multitrack Recorder and see if they can do anything.

  • I’ve found that I can change NS2’s sample rate by opening AUM (if you have it) first, and changing it’s (AUM’s) sample rate.

    (Don’t know what would happen once the interface is introduced)..

    With MTR, it will only play properly with the original (what you recorded at) rate.
    (So start as you mean to go on) etc..

    ..
    King
    .

  • edited November 25

    yeah definitely this needs to be solved in Multitrack.. it must resample all internal wavs into sample rate which is used by device (or by host app, in case it is running as plugin not as standalone app)

    For example NS2 does this - all
    samples loaded into Obsidian / Slate are always resampled to sample
    rate tused by device, som you can use in Obs/Slate samples with any sample rate from 22khz till 96khz - it always plays right, no matter off device sample rate

  • edited November 25

    MTR TIP:

    If you have for example, a project set @ 48.000Hz, & you want it to play at 44.100Hz, (or vice versa) what I did was to create a new project at 44.1k, then imported the clips, which are automatically converted.

    For me I only had to do this once, as any project from then on is set to 44.100Hz.

    ..
    King
    .

  • Haha,

    We are all writing at the same time (overlapping).

    It’s all good!

    ..
    King
    .

  • @King said:
    MTR TIP:

    If you have for example, a project set @ 48.000Hz, & you want it to play at 44.100Hz, (or vice versa) what I did was to create a new project at 44.1k, then imported the clips, which are automatically converted.

    For me I only had to do this once, as any project from then on is set to 44.100Hz.

    ..
    King
    .

    The problem I am finding is that I cannot change the sample rate of the project as it uses the host sample rate.

  • P.S Paul (MTR Developer) is aware of this, - I know I wrote to him about it early Nov.
    (but as I sussed it out, and wrote it in the mail) I’m not sure what his position is on the matter.

    ..
    King
    .

  • edited November 25

    @BjørnFelle said:

    @King said:
    MTR TIP:

    If you have for example, a project set @ 48.000Hz, & you want it to play at 44.100Hz, (or vice versa) what I did was to create a new project at 44.1k, then imported the clips, which are automatically converted.

    For me I only had to do this once, as any project from then on is set to 44.100Hz.

    ..
    King
    .

    The problem I am finding is that I cannot change the sample rate of the project as it uses the host sample rate.

    If I’m understanding you correctly, you would/will have to do that in standalone MTR. ..and import clips.. etc.. mentioned in the tip!

    ..
    KIng
    .

  • edited November 25

    This is part of the mail I sent on the 8-11-19:

    “Just ran into a big issue. Had a session going in NS2, the sample rate was (48.000Hz), and all was playing fine. Playing a sample I recorded in MTR standalone. So I thought I would refresh and restart NS2, now the file is playing slower, and the nanos sample rate is now (44.100Hz). I’ve tried to create a new project to see if I could get it back, but no joy. Can’t see anywhere to change NS2’s sample rate. It be nice if MTR could just work with 44, that’s what most of my equip/apps are set to.

    Edit: the reason NS2 was set to 48, was because I had AUM open in the background before starting NS2 - (luckily). So if I start AUM and set it to 48, then start NS2, nano will follow suit, but I can’t continue to do that each time. Even if I was to host nanostudio in AUM, I would have to keep disabling and enabling Ableton Link, because AUM will change NS2 bpm. I suppose I could disable link from NS2 - but..”

    ———-
    ..
    King
    .

  • edited November 25

    Here is a reply from the developer:

    “The sample rate you need to watch and always ensure you stick to the same sample rate, especially if you are attempting to load MTR within different DAWs.

    My advice here is:-

    When you load the plugin the first step should ALWAYS be to create a New Song. This ensures the session is setup with a sample rate and tempo that matches the host app.
    If you think there is a mismatch you can check using the Song -> Song Details option
    Beware of background apps forcing the wrong sample rate from under your nose. This needs to be avoided.”

    ———-
    I was aware of the above ^, hence my edit etc..
    (The advice is good going forward)

    Yep! It needs sorting though, when this happened to me, I had to get in touch with SynthMaster Players developer, as that went all wonky. Etc
    Bonus! Levent will be fixing SMP ASAP.

    ..
    King
    .

    I must feel like writing today..

  • Thanks dude, I appreciate you getting in touch with the developer. I don't think it's as simple as this, however. The song details in MTR do say 48k, but the sample is at 44 and it doesn't play it correctly. Only by re-exporting the sample at 48khz can I get it to play correctly in MTR.

  • edited November 25

    @BjørnFelle said:
    Thanks dude, I appreciate you getting in touch with the developer. I don't think it's as simple as this, however. The song details in MTR do say 48k, but the sample is at 44 and it doesn't play it correctly. Only by re-exporting the sample at 48khz can I get it to play correctly in MTR.

    Huh!

    Could you take a grab?
    And show what you mean.

    Also:

    ..
    King
    .

  • edited November 25

    Just gathering all the info I can surrounding this issue, they may help you piece it together:

    I’m 100% aware this ^ is slightly different, but it’s related.

    ———-

    “MTR do say 48k, but the sample is at 44 ”

    ———-

    ..
    King
    .

    Added: Contact Paul.

    ✌🏼

  • I'll post some screenshots tomorrow, after my gig tonight. After spending most of the day re-exporting, re-mastering and re-importing my live tracks in 48kHz and finally getting my set sorted for tonight, I don't want to start changing anything to take screenshots ;)

  • edited November 25

    No worries!

    (Although there is nothing to change). (Shouldn’t be)

    Have fun! (gigging)!

    ..
    King
    .

  • @King said:
    No worries!

    (Although there is nothing to change). (Shouldn’t be)

    Have fun! (gigging)!

    ..
    King
    .

    Thanks man :)

Sign In or Register to comment.