MIDI out - can you use NS2 to sequence AUM?

I have a session set up in AUM and I wanted to sequence it with NS2. I created an External MIDI track, recorded some notes, and made sure that AUM is selected as a destination in the main settings page.

However back in AUM if I select the AUM Destination as my input, no MIDI is being sent from NS2. The playheads in both apps are running, but it doesn’t look like NS2 is actually outputting the MIDI.

Comments

  • I’ve just tried to do something much simpler: drive Animoog using NS2’s External MIDI Track and no dice. The problem is that NS2 doesn’t advertise its virtual MIDI port, which makes setting this up impossible.

    So how exactly does one use the External MIDI Track?

  • Hi @richardyot - I might have misunderstood, but with external midi tracks you set the midi destination for an external midi track here:

  • edited August 30

    @richardyot said:
    I have a session set up in AUM and I wanted to sequence it with NS2. I created an External MIDI track, recorded some notes, and made sure that AUM is selected as a destination in the main settings page.

    However back in AUM if I select the AUM Destination as my input, no MIDI is being sent from NS2. The playheads in both apps are running, but it doesn’t look like NS2 is actually outputting the MIDI.

    This works fine for me. Are you sure you have background audio enabled in NS2?

    [edit ... after re-reading, @Trigger_the_Monkey ’s answer seems more likely to be the right one. ]

  • @richardyot said:
    I’ve just tried to do something much simpler: drive Animoog using NS2’s External MIDI Track and no dice. The problem is that NS2 doesn’t advertise its virtual MIDI port, which makes setting this up impossible.

    So how exactly does one use the External MIDI Track?

    This can be done by hosting Animoog in AUM, routing “AUM Destination” to it, and sending NS2 midi out to AUM. Midi in doesn’t need to be set in Animoog because it will be handled by IAA in AUM.

  • @Trigger_the_Monkey said:
    Hi @richardyot - I might have misunderstood, but with external midi tracks you set the midi destination for an external midi track here:

    That's what I was missing! Thanks. I didn't realise you had to tap on the piano icon on that screen, I had been tapping on the other icons at the top right.

    Once I tap on the piano I can select AUM as the destination and it works.

    I read through the manual but I couldn't find this.

  • @dendy said:

    @richardyot said:
    I read through the manual but I couldn't find this.

    here ;-)

    https://www.blipinteractive.co.uk/nanostudio2/user-manual/ExtMIDIInstrument.html#setup

    Thanks - I didn't find that when I looked.

Sign In or Register to comment.