Using midi keyboard and saving settings

I could use a little help. I seem to always have to re “learn” all my midi mappings. I can’t find anything on how to save them. Ideally I would like to set it up and keep it that way no matter what patch i use. Thanks

Comments

  • tap on that grey row above mappings, where you see text "USING 'yourmidiport' MAP" - there you can save your current mapping as default for that given midi device - every new channel with same midi device and instrument will then load by default that mapping...

  • @dendy said:
    tap on that grey row above mappings, where you see text "USING 'yourmidiport' MAP" - there you can save your current mapping as default for that given midi device - every new channel with same midi device and instrument will then load by default that mapping...

    I really thought I would have figured this out by now. When I hit “save as default” and then switch over to another synth and hit “load defaults” it does not load the one I just saved. If you could explain how this works I would appreciate it.

  • @InterestingBee said:

    @dendy said:
    tap on that grey row above mappings, where you see text "USING 'yourmidiport' MAP" - there you can save your current mapping as default for that given midi device - every new channel with same midi device and instrument will then load by default that mapping...

    I really thought I would have figured this out by now. When I hit “save as default” and then switch over to another synth and hit “load defaults” it does not load the one I just saved. If you could explain how this works I would appreciate it.

    Are you using Obsidian or AU instruments?

  • edited January 8

    you don't need load defauls manually... if you saved it, next time you load SAME instrument type on track, it automatically loads your saved mappings dor that instrument type

    Thise mappings are simply saved "per instrument type" (obsidian, slate, au instrument, midi out instrument)

    "load defaults" is just way to revert back to app defaults ;)

  • @Will said:

    @InterestingBee said:

    @dendy said:
    tap on that grey row above mappings, where you see text "USING 'yourmidiport' MAP" - there you can save your current mapping as default for that given midi device - every new channel with same midi device and instrument will then load by default that mapping...

    I really thought I would have figured this out by now. When I hit “save as default” and then switch over to another synth and hit “load defaults” it does not load the one I just saved. If you could explain how this works I would appreciate it.

    Are you using Obsidian or AU instruments?

    >
    Au but as far as I can tell it just never saves my mappings not matter what. Every time I hook up my keyboard I have to reset all mappings

  • @InterestingBee said:

    @Will said:

    @InterestingBee said:

    @dendy said:
    tap on that grey row above mappings, where you see text "USING 'yourmidiport' MAP" - there you can save your current mapping as default for that given midi device - every new channel with same midi device and instrument will then load by default that mapping...

    I really thought I would have figured this out by now. When I hit “save as default” and then switch over to another synth and hit “load defaults” it does not load the one I just saved. If you could explain how this works I would appreciate it.

    Are you using Obsidian or AU instruments?

    >
    Au but as far as I can tell it just never saves my mappings not matter what. Every time I hook up my keyboard I have to reset all mappings

    Hmm. That's a weird one. On the Mixer -> AU Instrument channel -> SETUP tab, at the top of the list on the right it should say something like "USING (your selected midi port) MAP". Can you tell us exactly what that says? Also, what controller are you using and how do you hook it up to your iPad?

    And, just to make sure I'm understanding the problem you're having, let me verify that once you've done all of your MIDI Learning, you tap that top bar and then tap "Save as defaults for '(your midi port)' but the next time you add a track using the same MIDI port, those mappings are gone?

Sign In or Register to comment.