ReSlice not playing correctly in NS2 ✌🏼

edited January 20 in Support

Hey Matt,
@Blip Interactive

I mentioned it a few times before but here is a little more detail.

Please find 2 screenshots below:

First is just showing the Arp settings, you can test with the “Dubstep” preset but may need to change Arp so it plays the whole sample, as I have done. (I also use “Key Sync”)

Second is showing how much I need to move —> the midi note for it to play “almost” correctly.

When pressing f.e “C” whilst the transport is playing, all is well.
But once I press record, the first few seconds are scrambled and jumbled.
This “Scrajumbled” is heard during playback of the recorded note(s). (Test with 1 note)

Also, once the track has looped “or” 2 parts play in succession, it plays fine - but stop n start displays the same behaviour... scrajumbled.

(When I am bug testing, I will/always create new projects to make sure)

(..also, ReSlice works fine elsewhere)

Cheers

King

—————

P.S, that last screenshot was not easy to capture - had to use all my fingers n toes..

Comments

  • These 3rd party compatibility issues need addressing ASAP by Blip. SPA and ReSlice are two of my most used AU in other hosts :(

  • @King Thanks for precise description, we will look at this cockroach !

  • edited January 23

    finally got some time to try this

    confirming there is some issue with syncing arpeggiators - until arps are turned off, slices are played correctly based on incoming notes from NS - but there is some issue with Arps, looks like they are not receiving correct information about host temoo and playhead position (in Cubasis it works perfectly in sync with host playhead)

    @Blip Interactive if you want, here is my test project - https://www.dropbox.com/s/lt38uzwq3mxttgh/Example.nsa?dl=0
    it should play first slice on every beat (it’s played by arpeggiator 1) - but in NS you hear weird mess of various slices and arpeggiators internal playheads are completely at wrong position

  • edited January 23

    @dendy said:
    ... - but in NS you hear weird mess of various slices and arpeggiators internal playheads are completely at wrong position

    Yeah, technical term is: “scrajumbled”. ©️

    Cheers

    King

  • @Blip Interactive said:
    I still can't get Reslice to play ball even with the changes I've made. It isn't happy when NanoStudio moves the song position to exactly to the start of the next note it should play (either via a user interaction, when the song loops whilst playing or at the start of the song). Seems to be worst when its arpeggiator is set to 'key sync' mode.

    I'm sure I'm just passing it the wrong info somewhere along the line but I've checked it many times and nothing stands out. Fortunately I've managed to get in touch with the developer and he's kindly offered to take a peek from the inside - hopefully he should be able to quickly spot what I've screwed up.

    Pasted/quoted this here, cos, well, OCD and such..

    King

  • Thanks, was half thinking of doing that myself. Then I thought no, that's proper OCD right there :)

  • @Blip Interactive said:
    Thanks, was half thinking of doing that myself. Then I thought no, that's proper OCD right there :)

    Haha, I know, I know!

    I tell you what though, I know you have it, because there is a LOT of perfection in NanoStudio 2, ... too..

    King

  • edited January 30

    @dendy said:
    finally got some time to try this

    confirming there is some issue with syncing arpeggiators - until arps are turned off, slices are played correctly based on incoming notes from NS - but there is some issue with Arps, looks like they are not receiving correct information about host temoo and playhead position (in Cubasis it works perfectly in sync with host playhead)

    @Blip Interactive if you want, here is my test project - https://www.dropbox.com/s/lt38uzwq3mxttgh/Example.nsa?dl=0
    it should play first slice on every beat (it’s played by arpeggiator 1) - but in NS you hear weird mess of various slices and arpeggiators internal playheads are completely at wrong position

    Set Hold/Sync to Standard and move your clips down the timeline 1 measure. Set the loop to the clips. Rewind to the beginning of the sequence (not the loop) and play. It will start and loop perfectly.

    PS - never mind. It starts to go out of sync. I had some stuff working fine but... will have to look at this a little more. :s

Sign In or Register to comment.