SOLVED: Decimate and Bit Crush always 100%?

edited February 2 in Support

Hi folks. NS2 awesome so far. Enjoying learning/adapting from NS1 and currently attempting to recreate some of my NS1 Eden patches in Obsidian.
There seems to be a bug in the WS filter type: the decimate and bit crush controls seem to be locked to 100%. Set the mix to 100% and they have no audible effect across their entire range. The signal is just totally decimacrusherated. They are dual labelled, with “cutoff” paired with “decimate”. Am I missing a trick here to switch those controls to the secondary parameter?

Comments

  • @pipstyles said:
    Hi folks. NS2 awesome so far. Enjoying learning/adapting from NS1 and currently attempting to recreate some of my NS1 Eden patches in Obsidian.
    There seems to be a bug in the WS filter type: the decimate and bit crush controls seem to be locked to 100%. Set the mix to 100% and they have no audible effect across their entire range. The signal is just totally decimacrusherated. They are dual labelled, with “cutoff” paired with “decimate”. Am I missing a trick here to switch those controls to the secondary parameter?

    Not seeing this here. Works as expected.

  • edited February 1

    @pipstyles

    if you switched to "WS" for example filter 2, check dobre what is set in marco XY pad -> filter modulation settings and also Filter Envelope -> filter modulation settings - they are set to target Filter 1+2 by default, so if you for example use Filter 2 as waveshaper, you need change XY pad and filter envelope modulatios pointing just to Filter 1 otherwise they are modulating also your waveshaper :)

  • @dendy said:
    @pipstyles

    if you switched to "WS" for example filter 2, check dobre what is set in marco XY pad -> filter modulation settings and also Filter Envelope -> filter modulation settings - they are set to target Filter 1+2 by default, so if you for example use Filter 2 as waveshaper, you need change XY pad and filter envelope modulatios pointing just to Filter 1 otherwise they are modulating also your waveshaper :)

    Good one.

    @pipstyles If you want to recreate Eden patches, put the waveshaper on Filter 3. Filters 1 and 2 are "per voice" filters whereas Filter 3 is a global filter (just like the effects in NS1).

  • @Will said:

    @dendy said:
    @pipstyles

    if you switched to "WS" for example filter 2, check dobre what is set in marco XY pad -> filter modulation settings and also Filter Envelope -> filter modulation settings - they are set to target Filter 1+2 by default, so if you for example use Filter 2 as waveshaper, you need change XY pad and filter envelope modulatios pointing just to Filter 1 otherwise they are modulating also your waveshaper :)

    Good one.

    @pipstyles If you want to recreate Eden patches, put the waveshaper on Filter 3. Filters 1 and 2 are "per voice" filters whereas Filter 3 is a global filter (just like the effects in NS1).

    Oh hey, good point. Wish I’d sussed that a year ago 😖

  • edited February 1

    @Will said:

    @dendy said:
    @pipstyles

    if you switched to "WS" for example filter 2, check dobre what is set in marco XY pad -> filter modulation settings and also Filter Envelope -> filter modulation settings - they are set to target Filter 1+2 by default, so if you for example use Filter 2 as waveshaper, you need change XY pad and filter envelope modulatios pointing just to Filter 1 otherwise they are modulating also your waveshaper :)

    Good one.

    @pipstyles If you want to recreate Eden patches, put the waveshaper on Filter 3. Filters 1 and 2 are "per voice" filters whereas Filter 3 is a global filter (just like the effects in NS1).

    That has worked, thanks! It does seem broken on filters 1 or 2 though. I tried @dendy suggestion about the xy pads (correct, the default was that) but remove those controls didn’t alter the behaviour or WS mode on filter 1 and 2.

    So, WS filter on the global filter works fine.

    Edit: yes! Default filter envelope was causing the setting on the filter control to be overridden. A bit tricky that. Lesson: parameters in various places can be overridden by various controllers and envelopes and you won’t know until you really look in the right places.

  • edited February 1

    @pipstyles

    try this path...

    https://www.dropbox.com/s/7et9xxlwbk0v3oo/Crush.zip?dl=0

    there is single osc (sine), filter 1 is, LP - XY, Filter Env snd LFO2 are set to modulate just Filter 1, on Filter 2 is Bitcrusher...

    try to tweak it's two knobs decimate / bitcrush - both are working like expected, from zero to max

  • edited February 1

    and here is switched order (together with all default filter modulations)

    osc > crusher > lp filter
    https://www.dropbox.com/s/lqp95g8eh9ez49n/Crush2.zip?dl=0

    additionally, i did set macro 3,4 to crush and decimate so you can play directly from macro screen ;)

  • @pipstyles said:
    Edit: yes! Default filter envelope was causing the setting on the filter control to be overridden.

    Ack. Of course. Sorry I didn't think of this. Was the source of much similar confusion with Eden.

    Anyway, glad you sorted it!

Sign In or Register to comment.