Onscreen keyboard only white or only black keys?!?

I played around with Tera Synth and tried to play a whole octave, moving a finger from one side to the other side.
But the onscreen keyboard only plays the black keys, or the white keys.
But not the whole octave.

This was totally unexpected by me.

I then switch to other AU Apps, but this seems to be the nanostudio keyboard, not one of the AUs.

Am I missing something, or is there a way to play all keys, as with any other onscreen or real keyboard?

There ARE white keys between the black keys ;-)
Why skip them?

confused

Comments

  • I have MicroTERA, so I loaded it up and I don’t see this same behavior. It plays chromatically as expected if I slide my finger up the keyboard left or right.

  • @drez said:
    I have MicroTERA, so I loaded it up and I don’t see this same behavior. It plays chromatically as expected if I slide my finger up the keyboard left or right.

    I repeated with microTera, to the same avail...
    It's independed to the AU.

    You have Scale set to "Off"?

  • tjatja
    edited February 5

    BTW, I realy hate this "Untitled-5328" names.
    Better use a proper datetime string:

    <YEAR>-<MONTH>-<DAY>T<HOUR>:<MINUTE>:<SECOND>
    

    http://support.sas.com/documentation/cdl/en/lrdict/64316/HTML/default/viewer.htm#a003169814.htm

  • edited February 5

    As i know this is expected behaviour, intentional... Feature not bug:-)

    keyboard is splited to two touch areas - upper one for black keys and bottom one for white keys - so even on smaller screens is little chance you type wrong key..

    As user i'll say thangs god for this feature, NS build in keyboard is thanks this only one where i'm able to play on black keys without misstyping white one...

    Slide over all keys is possible if you activate "scale" mode and switch to "chromatic" - if you set in app settings > UI key width to "narrow" you can see more than octave in "chromatic" scale mode..

    hope it helps ;)

  • edited February 5

    This is how it works.
    You can get around this by setting the keyboard scale to Chromatic, which makes all keys the same height. For more range, set your key width to narrow and you can also use the ”double keyboard” layout on the performance page. It’s not perfect, personally I would also prefer the white keys to accept touches in the black key area.

    If you want to experiment, you can also use another keyboard app to drive NS.

  • Many thanks.
    I am not even sure that I would need this, but as always, a settings toggle to enable "regular" behavior, would be nice.

  • I agree, and glad to be of help!

Sign In or Register to comment.