Obsidian Sampler: mystery delay echo—how to get rid of it?

Hi—just bought NS2 and loving it! I love it SO much that one of the first things I want to do is create a bunch of Obsidian sampler patches so I can work with some of my favorite acoustic instrument samples (mostly percussion).

I’ve read everything I can find on the Obsidian sampler module (which isn’t much) and also watched the one video, which unfortunately doesn’t address my issue.

In a nutshell, before loading and auto mapping a sample, I want to initialize EVERYTHING. All I want to hear after loading samples is the raw, unfiltered, unaffected sample sound. Then I want to be able to tweak the envelopes, sustain loops, etc myself.

My process for this is to go through every possible “hamburger icon” that exists anywhere in Obsidian (not just the sampler module but the FX and all other panels too) and tap “Init” for every one. This almost works...except I’m still hearing a single, much quieter delay echo (a delay feedback of 1), and it’s DRIVING ME MAD!!! :-)

For the life of me I can’t figure out where this delay/echo is coming from. All effects are off/bypassed (that was the first thing I checked). I’d be eternally grateful if someone can help!

ALSO: What’s the simp,est way to save an “Init Patch” so I don’t have to go through this every time?

Thanks very much!
Scott in Oregon, USA

Comments

  • Okay, I thought I found the problem, which was that the sample was set to loop (took me a while to even find that parameter!). But alas, no, turning loop off (which I assume basically makes it a one-shot sample) didn’t help.

    When I hold a note down on the keyboard, the sample repeats. THIS is the problem. How do I stop the note from repeating?

    In other words, if I tweak the envelope so there is a nice release, that repeat of the note is the echo I’m hearing (except much fainter because it’s downstream of the envelope). And the note repeats regardless of whether I hold the note down or not.

    I’m sure this is something obvious to someone, and apologies—I’m far from being a sampler guru. Seems like some sort of LFO is repeating the notes, so I just need to disable this or set it’s value to zero. (I want one-shot, non-sustained samples.)

    Thanks!
    Scott

  • edited April 14

    Hi and welcome.
    If you loaded a factory patch and tried to initialize every sector in obsidian by hand, you may forgot a few more bits.
    You can initialize a patch by going in the patch list, press the hamburger button at the topmost right corner, under record. This will initialize all sections, a few you may forgot could be the patch bay (modulation matrix) and the effects section. ;)

  • edited April 14

    Welcome Scott

    • for total patch init go to patch browser screen, and go there into right hamburger menu and there hit "init" - you don't need initialize each module individually ;)

    • to turn off looping of sample, go to sampler oscillator settings - select sample zone - go to tab "param", hit left arrow on "LOOP" section - this turns off looping (you can switch between no loop, loop whole sample, looping of sustain loop, and spectal looping)

    Btw sustain loop points are stored inside wav file, you can change them with Nanostudio audio editor .... If sample doesn't have sustain loop points defined, whole file is looped even if "sustain" loop mode is set...

    If you use more sample zones, you don't need to turn off individually for each zone - you can turn them all from hamburger menu of Oscillator - with any aone selected, hit wrench icon amd in menu which appears choose "set sample loop > off"

    • there is small release "tail" in default init patch - maybe that's "delay" you hearing - just decrease release knob on AMP envelope

    If you tweak init patch and you can use this tweaked as init patch (eg. everytime you hit "init" in patch browser hamburger menu, this your tweaked patch will be used for initialisation

    Hope i answered everything you needed to know ;-)

  • THANK YOU Zupi and dendy—I appreciate the great advice and instructions! Haven’t tried this yet but am about to now! :-)
    Scott

  • Nah... Dendy is your one stop to Online Interactive Manual Clarification. It’s just he has and a life to live so he might not be around all the time.

Sign In or Register to comment.