Am I right in saying that no one has found a bug yet?

124

Comments

  • @Brattcave said:
    @dendy Was going to just suggest that - apologies, didn't mean to derail things. I have a tendency to go into detail :) Cheers.

    no reason to apologize ;)
    btw i'm going to sleep now (01:39am here ;)) but for sure we will sooner or later solve this puzzle ;)

  • No worries - troubleshooting is how I get to learn most apps. I haven't solved this problem yet but I've learnt loads by poking around in the corners. All whilst playing of course :)
    Have a good one.

  • @hansjbs said:
    My comments was not directed at you.

    OK cool. Just let me know if I am being offensive. I’ll try a little extra not to be.

  • Would this be a good thread to congratulate Matt @Blip Interactive with a monumental achievement and an incredibly smooth launch? I think most developers will agree that launching an app this complex without significant bugs is a rare phenomenon.

    A stellar addition to the iOS landscape (and yet another host I need to test all my stuff in =) )

  • On a serious note, I have a Targus case keyboard I use, but haven’t for a few weeks. Is it one of the notebook style keyboards, or just wireless standard universal for all type keyboard? Or you think it might just be a Bluetooth related issue in general with keyboards/devices? I think that’s the only blue tooth device I have aside from my UE boom speaker but that’s worked good within NS2 so far.

    @blueveek said:

    @dendy said:

    @SlapHappy said:

    @blueveek said:
    Here’s a bug: ipad external keyboards (including apple’s smart keyboard folio) don’t work in NS2. Much sad.

    :o :o :o :o :o :o
    That's horrible! That's it. No Phase Magnum Distortion and now this. I'm gonna get a refund from the AppStore!

    don’t do this to me :lol: i started to laugh loudly and I almost woke up my son ... And you can imagine what would then do Mrs. to me, with her skills...

    Do y’all really think this is a reasonable reaction to a real bug report? Could really put off people actually trying to help.

  • It's quite telling that people have to search around to find something to report as a bug.

  • @nkdvkng said:
    On a serious note, I have a Targus case keyboard I use, but haven’t for a few weeks. Is it one of the notebook style keyboards, or just wireless standard universal for all type keyboard? Or you think it might just be a Bluetooth related issue in general with keyboards/devices? I think that’s the only blue tooth device I have aside from my UE boom speaker but that’s worked good within NS2 so far.

    It’s apple’s keyboard.

  • @brambos said:
    Would this be a good thread to congratulate Matt @Blip Interactive with a monumental achievement and an incredibly smooth launch? I think most developers will agree that launching an app this complex without significant bugs is a rare phenomenon.

    A stellar addition to the iOS landscape (and yet another host I need to test all my stuff in =) )

    Any thread is good for that. It would also be a good opportunity to tell you that you are one of the App Store developers pushing music making into the future. I love ruismaker noir!😁
    Any chance for a Hammerhead re-make?

  • Wow what a breathe of fresh air and what a day to make music mobile with so much power in your hands thanks to all the developers!

  • @iamhousemachine said:
    Wow what a breathe of fresh air and what a day to make music mobile with so much power in your hands thanks to all the developers!

    Single one developer ;)

  • With multiple personalities from various past lives that actually hold meetings in his head. =)

  • Not to stir the pot, I’m still curious about the pitch automation for Slate that was mentioned on the first page. I’ve found the only workaround for this is filling multiple pads with pitched samples and sequencing rather than automating.

    @blueveek said:
    I think this is a bug: pitch automation not working for Slate:

    This is orthogonal to actually wanting to automate pitch for single pads, which doesn't seem possible regardless of whether or not this bug was fixed.

    Is the Pitch Automation in the Pattern Editor only applicable to Obsidian?
    Are there other automation parameters in the Pattern Editor limited to Obsidian?

    Just curious if this really is a bug or if there’s something in the workflow I’m misunderstanding (the latter could easily be the case). Haven’t seen any follow-up posts on the subject though so figured I’d ask.
    If anyone has some insight on this it would be appreciated.

  • edited December 2018

    i'm asking myself if pitch automation in Slate makes sense at all ..

    i mean automation per whole Slate, which would affect all pads. It's drum sampler, in 99% of cases it makes no sense in my opinion.

    Ok, there always can be some obscure cases, or somebody wanted to do something weird... but really. Pitch shift automation for whole drum sampler ? :-) Would be interested for some non-obscure non-nerd musical use of such thing :-)

    Was something like that possible in NI Battery ?

    btw. i'm not questioning this bug and how it should be solved - just curious on musical use of such, to me, weird thing

  • @dendy My initial curiosity with the subject was when it came up in a thread about automating the pitch of hi hats in a pattern. Pitched hats and kicks are common in trap and current hip hop beats, so I can understand why it would be a desired feature for some users.
    I could also imagine it could help in sound design, it could be used to emulate a tape warp or something more obscure.
    I don’t necessarily see it as a bug, just curious why Slate would have that screen if it didn’t have automations. Doesn’t bother me since I don’t really use it, can’t stop wondering now though.

  • edited December 2018

    pitched hats and kicks are common in trap and current hip hop beats, so I can understand why it would be a desired feature for some users.

    Aach ok then it make sense. I'm completely out of those styles, didn't know that.

    I don’t necessarily see it as a bug, just curious why Slate would have that screen if it didn’t have automations.

    Yes, this is bug for sure, that lane should be disabled (not visible) or it should work. One of these, that's obvious. I was just interested if this is somewhere seriously used (to pitch whole drum sampler at once).

  • edited December 2018

    I had a Yamaha RX5 drum machine. One thing it had that was very cool and very useful was, in addition to the pads each triggering a specific drum, you could set it so that the top row of pads would control pitch, level, attack rate or decay rate for a single voice. So the row of pads from left to right could be assigned to any single voice and would scale from a lower to a higher pitch, from very quiet to full velocity, from a slow attack to an instant attack or from a very short decay to a long decay (the voice would loop). This could be entered in real or step time. There were also toggles to play any voice in reverse or to damp the previous voice so you could be entering drums in real or step time, turn on “reverse” or “damp”,enter a couple of steps in reverse or damp the decay of the previous step and then toggle reverse or damp mode off. Maybe functions like this could be added to Slate @Blip Interactive ? They are very powerful and very useful for creating dynamic drum tracks. I suppose pitch , attack and release could be added to the single pad mode although it would be nice if pitches could be on pads so they can more exact.

  • Not sure if it's been mentioned yet - FREE Launch Pack / INDEMO2 pad 1 and 10 refers to a missing sample INV2KK01-04. Can somebody confirm please?

  • @rec said:
    Not sure if it's been mentioned yet - FREE Launch Pack / INDEMO2 pad 1 and 10 refers to a missing sample INV2KK01-04. Can somebody confirm please?

    The sample is there. It plays on some of the other pads. You have to re-link the sample to the pad by choosing the pad and then navigating to the sample in the sample menu.

  • @anickt said:

    @rec said:
    Not sure if it's been mentioned yet - FREE Launch Pack / INDEMO2 pad 1 and 10 refers to a missing sample INV2KK01-04. Can somebody confirm please?

    The sample is there. It plays on some of the other pads. You have to re-link the sample to the pad by choosing the pad and then navigating to the sample in the sample menu.

    Yep, thanks!

  • @rec said:

    @anickt said:

    @rec said:
    Not sure if it's been mentioned yet - FREE Launch Pack / INDEMO2 pad 1 and 10 refers to a missing sample INV2KK01-04. Can somebody confirm please?

    The sample is there. It plays on some of the other pads. You have to re-link the sample to the pad by choosing the pad and then navigating to the sample in the sample menu.

    Yep, thanks!

    Glad to help!

  • I have a bug. Automation of the volume drawn in, on the main mix parent track, doesn’t reflect in the playback.

    Also when I insert an AUv3 on a channels signal chain, I can no longer automate anything on that track like volume or turning an effect on/off or automating it.

  • @nkdvkng said:
    I have a bug. Automation of the volume drawn in, on the main mix parent track, doesn’t reflect in the playback.

    you need activate track automation
    here: https://www.blipinteractive.co.uk/community/index.php?p=/discussion/50/cant-get-track-automation-to-work-volume-and-pan

    Also when I insert an AUv3 on a channels signal chain, I can no longer automate anything on that track like volume or turning an effect on/off or automating it.

    If i correctly understand this, answer is : it is not possible at the moment automate AUfx plugins, just build- in plugins (except of EQ3B)

  • @dendy said:

    @nkdvkng said:
    I have a bug. Automation of the volume drawn in, on the main mix parent track, doesn’t reflect in the playback.

    you need activate track automation
    here: https://www.blipinteractive.co.uk/community/index.php?p=/discussion/50/cant-get-track-automation-to-work-volume-and-pan

    Also when I insert an AUv3 on a channels signal chain, I can no longer automate anything on that track like volume or turning an effect on/off or automating it.

    If i correctly understand this, answer is : it is not possible at the moment automate AUfx plugins, just build- in plugins (except of EQ3B)

    Thanks Dendy! The automation on the main mix worked by selecting W.

    btw I was attempting to automate something on EQ3B, but your comment shows me that we can’t automate it just yet. Bummer, I wanted to do a low to high pass filter on a track.

  • W is for “write” - with “W” active if you tweak fader it records moves

    you have to activate green”R” at left side of W .. thats “Read”

  • edited December 2018

    @nkdvkng said:
    btw I was attempting to automate something on EQ3B, but your comment shows me that we can’t automate it just yet. Bummer, I wanted to do a low to high pass filter on a track.

    Instead of EQ3B use Stereo Filter effect... it contains all modes from EQ3B (+ 48dB LP/HP for chirurgical cuts), it’s like single EQ3B band but with automation

  • edited December 2018

    FREE Launch Pack / INDEMO2 pad 1 and 10 refers to a missing sample INV2KK01-04

    Sorry about that, I'll 'fess up - this was my totally ham-fistedness making a manual change at the last minute! I'll try and get round to updating the pack soon as it should be a simple change.

    I decided not to automate the entire 3-band EQ as it started making the automation list a bit unwieldy and I wanted to keep it fairly lean and mean. I agree this is a little controversial, but I convinced myself I could apply the 80/20 rule where 80% of the time you usually want to automate just a single band's cutoff to do a sweep, or maybe a shelf gain to provide a little lift. So (as Dendy mentioned), the Stereo Filter is the get-out for this when you need it and you can put of couple of them in series if you need more.

  • Some freezes happen to me from time to time when saving. But after a while it just goes back to normal. I don't lose what I have done, which is a good thing.

  • Here’s something I noticed today: when mapping some parameters to Obsidian Knobs 1 and 2 on an initialized Obsidian patch, the labels didn’t change. I think they stayed labeled as cutoff and Q, or something like that. Might be something to check out.

  • Some freezes happen to me from time to time when saving. But after a while it just goes back to normal. I don't lose what I have done, which is a good thing.

    Are there any Audio Units in your project?

  • Here’s something I noticed today: when mapping some parameters to Obsidian Knobs 1 and 2 on an initialized Obsidian patch, the labels didn’t change. I think they stayed labeled as cutoff and Q, or something like that. Might be something to check out.

    Sounds like they've been given custom names. Try this:

    • Go to Obsidian's PERFORM page
    • Tap on the hamburger button (top right) and choose the macro control you want to change
    • Choose 'Rename'
    • Delete the custom name and tap OK
Sign In or Register to comment.