filter #2 not active in parallel or stereo, only in series

Hello,
It does not seem like filter #2 is active when filter routing is set to parallel or stereo.
I have tried this on a freshly initialized patch.
I have tried through all 3 oscillators.
The filter path selection is set to go through the two filters, not bypass.
Filter #1 seems to work as expected.
Both filters work when using series routing in the filter setting.

Is there something I am missing or don't understand?

Latest version of Nanostudio2 on iPad Pro 12" that has latest IOS.

Thanks,

cb

Comments

  • edited August 15

    I'm pretty sure filter #2 is working in all routing configuration - it is used a lot in factory or IAP patches :)

    Are you sure you enabled it ? By default filter #2 is disabled, you need to tap on it's enable button (at left side of "FILTER" text) - filter then switch from grey to blue (or what is color of track) which means it's enabled

    Dont' forget that filters 1/2 are by default modulated by X pad and Filter envelope (and LFO2, where both Filter Env and LFO2 amount is on zero in default patch) - so if you use for filter 2 something different that standard filter - like Waveshaper - it may sound at first look it is not working, or it is not doing what you expected - you need to remove Filter Env and X pad mapping, chahge them from "Filter 1+2: Cutoff" to "Filter1: Cutoff", to have unmodulated Filter2 controls

  • edited August 16

    @oxcart400 said:
    Hello,
    It does not seem like filter #2 is active when filter routing is set to parallel or stereo.
    I have tried this on a freshly initialized patch.
    I have tried through all 3 oscillators.
    The filter path selection is set to go through the two filters, not bypass.
    Filter #1 seems to work as expected.
    Both filters work when using series routing in the filter setting.

    Is there something I am missing or don't understand?

    Latest version of Nanostudio2 on iPad Pro 12" that has latest IOS.

    Thanks,

    cb

    What dendy said, except in Stereo mode the filters 1 and 2 are linked (and the section name is changed to Filter L+R), one handles left and one handles right, so that is working as intended.

    Obsidian has two mono filters that can be combined into one stereo filter. Global filter is stereo.

  • Definitely looking forward to some patches illustrating issue but my bets are it's just some hidden forgotten modulation route :) It was happening to me often first few months with Obsidian ;-)

    After i made 220+ factory patches (and another 150 which i have ready for future distribution, when i decide how) - i'm at 99.9999% sure there is no bug in filter routing :-)

    But ok. If somebody founds bug, then big shame on me for not catching it yet :lol:

  • AAah .. ok this might be issue .. i will do some checks today evening too ...

Sign In or Register to comment.