All midi notes with midi channel > 1 are converted to 1 when sent to instrument

edited August 16 in Bug Reports

-------- short bug description ------
when midi notes send on midi channels 2,3,4,5,6..etc are send to other track (using midi send or "send midi to parent" in IN/OUT channel settings), they arrive or target track with proper midi channel number, but then they are sent to plugin on that track aways with fixed midi channel number 1
-------------------[ dendy ]---------

I've got one instance of BeatHawk loaded on a track, with different instruments set to each pad. BeatHawk has a "MIDI Select" feature that allows sending MIDI to each pad using the corresponding MIDI channel. What I want to do is create multiple tracks in NS2, each one sending to a different MIDI channel of this one BeatHawk instance.

Here's what I did, which I thought would work: I created multiple "no instrument" tracks that are all children of the BeatHawk track. For each track, I added the "MIDI Clone & Filter" effect from "MIDI Tools", which redirects all MIDI instructions to a different channel. The out for each of these tracks is set to go to the parent track (i.e. BeatHawk).

If I add a MIDI monitor effect after the Clone & Filter, I can see that the note information is being updated to the correct MIDI channel. However, BeatHawk seems to be getting all MIDI information on Channel 1...

Am I doing something wrong, or is this a consequence of a known limitation of NS2?

Comments

  • Do not insert "Clone" plugin on Beathawk track - just on child tracks... set proper channel in each chil track plugin (1,2,3). so you will not use plugin's routing functionality, just it's filtering functionality.

    For routing notes from child to parent track we will use directly NS midi routing festure.

    So, now just on each child midi track enable "send midi to parent" - and Beathawk will receive notes on proper channels.

  • Thanks a lot for the response, Dendy!

    Unfortunately, that's exactly how I have things configured and BeatHawk is still only receiving MIDI on Channel 1 (BeatHawk actually labels the channels 0-15, so Channel 0 in BeatHawk)...

    I can tell the MIDI in to BeatHawk is on Channel 0 because if I go into BeatHawk's settings and disable MIDI input on all other channels, I still hear the pad on Channel 0, but if I disable Channel 0, no sound.

    I haven't tried another AU yet to see if it's an issue on BeatHawk's side.

  • edited August 15

    hm that's weird, i tried it and it was working ok... i don't have beathawk but ininserted midi monitor on parent track and notes from child tracks were coming on right channels (1,2)

    i will upload project later and you just switch AU instrument on parent track to beathawk

  • Just tested BeatHawk with a similar setup in AUM (MIDI source -> MIDI C&F x 2 -> BeatHawk) and it worked as expected, so I'm not sure what's going on. Thanks again for trying to help!

  • edited August 16

    Ok, confirmed this as bug, moving task to "bugs" are and renaming title...

  • Roger that. Thanks for confirming it as an issue, WinConway and dendy.

Sign In or Register to comment.