Using a midi fx sequencer to record

I guess I’m missing something here, but rather new to this.
I’m trying to record to track using an AUv3 midi sequencer attached to an AUv3 synth. When I hit the record button, the play head rolls, sound is generated, but it’s not layer down (recorded) to the track. I can record if I play the synth with the keyboard, but not from the sequencer plug in. Is this possible?

Comments

  • edited October 22

    NS2 currently cannot direcly record MIDI output from AUfx MIDI plugin into sequencer .. hovewer there are workarounds...

    • if you use iPad, most simple way is MIDI Tools Route plugin. When you put this plugin after sequencer plugin, and then you add another track in midi sequencer, select this track and hit record - notes generated by sequencer AU plugin will be recorded to this track. Here is example video with Rozetta Arp.

    • if you use iPhone, MIDI Tools plugin suite is not available there - so you need use some external app to route NS MIDI out back in NS MIDI in and again - record it then to track in NS sequencer.. Basically put that AU sequencer on track with "External MIDI" instrument .. add some external app (for example Midiflow, or Audiobus MIDI) .. then route "External MIDI" instrument to that app and from that app back to nanostudio .. Now, add new track to nanostudio, select it, hit record - done. Notes from AU sequencer will be recorded to this track ... here is more detailed description of this workflow with some screenshots https://www.blipinteractive.co.uk/community/index.php?p=/discussion/989/how-to-record-aufx-midi-out-on-iphone

  • Tried, and worked. Many thanks for this Dendy. Has made my morning....

Sign In or Register to comment.