Recording midi from a midi track into another midi track

Hello everyone,
Newbie here. Only one question: How can I record from one midi track that has a midi FX, into a new midi track so I can capture the proer midi data? I’m somewhat confused as to how to go about this. I appreciate any info on this topic.



  • edited March 2019

    Can’t. Midi FX output just can’t be recorded in any way other then hosting the plugin in an external host and sending the midi to Nanostudio.

    Midi FX midi gets stopped at the instrument on the channel and just disappears after that. The issue is acknowledged and is being worked on.

    [edit] fun fact. That’s Iron Eyes Cody. I met and spoke with him a couple times as a kid in the Boy Scouts. He was as cool a guy as he looks.

  • Hey man thanks for clearing that up. Hope to see that feature real soon. :#

    Wow! That’s pretty impressive you’ve met him. Those were classic commercials/PSA’s.

  • edited March 2019


    You can use for Photon AUv3 plugin - it's midi fx which records midi... after you record it, dpfirst save it inside Photo, then use Photon’s share feature (choose “copy to nanostudio" ) which saves midi to nanostudio's "library/index" folder.. from there you can dragnrop midi file in sequencer directly to track

    Hope to see that feature real soon.

    yeah it's on todo list

  • Hey dendy, thanks for the tip man! I’m going to grab Photon right now. I love mangling midi info and this is a great workaround. Looking forward to future updates.

  • Hi Dendy, I’m having trouble getting this to work.

    I’ve got Photon as a MIDI FX on an Obsidian track (just like I can see you have) but I can’t get it to record any output from another MIDI FX AU (such as Autony, SPA Unit, or any of the Rozeta ones).

    Am I missing something? Can you perhaps show some more screenshots to explain your setup?


  • edited March 2019

    ok guys now i feel dumb, i’m very sorry but i missinformed you :(( It works in beta version but not in public version, there is bug in midi fx chain which causes that midi is not send to Photon .. i completely forgot this :((

  • Hey, no problem. I’m using Photon instead as a way to capture generated MIDI in AUM. I can still get it into NS2 from there in the way you describe - it’s just generated in a different context.

Sign In or Register to comment.