AU issues. Loading editor

Hello!
Been using NS2 since about March or April. Just a hobbyist. Nothing deep, extensive or complicated.
Never had this issue until this week or so (though, to be fair I’ve not had the opportunity to mess about with any music stuff for more than a month so if an update borked something somewhere during the interim I wouldn’t know until now of course).

I keep seeing this with a few AUs (so far). And here it stays. The instrument, not the project.

This is happening with D1, FM Player 2, and as you see Viking. Though not with, say, Kauldron or OB-Xd. D1 and FM Player work fine in stand alone mode.

Deleting the instrument or entire track, restarting NS will not bring it back. Not even restarting the iPad. It seems....seems...that once one decides to go kaput...it stays that way. Even loading that same synth in a totally different project after is a no-go.
iPad 6th gen/2018. iOS 13.2.3

Cheers!

Comments

  • I had that problem with Viking once. Restarting my iPad fixed it though.

  • Works on my iPhone 6 and iPad Air 1. Both are on 12.4.2 however.

  • Come to think of it, it was on my iPhone on iOS 13 where I had the issue. My Air 2 on iOS 12.3.1 was fine. Viking didn’t want to load up with a preset in a project I transferred from the iPad. I removed it, re-added it, then loaded the preset to get it working on the iPhone.

  • edited November 24

    audiokit synths issues are known, as i know they are working ond audiokit update for fixing these issues (saw mentioned it somewhere at AB forums but really don't know more about it)

    until then, unfortunately their synths are not useable in NS... There are more problems with AK synths - multiple instances are crashing also in other hosts... we just need wait and hope they will fix it

    never had such issue with viking aˇ- always been super stable for me. i would suggest to locate crashlog and send it to Viking dev.

    crashlogs are located in ios settings, under "Privacy > Analytics > Analytics data"
    In that list locate file with plugin name and datetime of when in crashed. Tap file, in top right corner you can see share icon (like in screenshot bellow).

    Send that file to dev of plugin ;)

  • I’ve had this same problem with various AUs, can’t remember them all, but most recently Rozeta XOX. Sometimes reloading the song fixes it for me.

  • @Shabudua said:
    I’ve had this same problem with various AUs, can’t remember them all, but most recently Rozeta XOX. Sometimes reloading the song fixes it for me.

    what device and iOS version ?

  • @dendy said:

    @Shabudua said:
    I’ve had this same problem with various AUs, can’t remember them all, but most recently Rozeta XOX. Sometimes reloading the song fixes it for me.

    what device and iOS version ?

    iPad 2017, various iOS versions. Sorry I haven’t kept track. 😖

  • edited November 24

    Ok, in case you will experience something, let us know, it's good t gather more information. Based on my experience - most of AU related issue which happened last 3-4 months needed fix in plugin - so it is always good to send message also to plugin dev.

    Of course - one never know ... this is complicated area, boundary between host and plugin is blury and iOS itself is not helping by it's poor documentation or practice to shut down plugin randomly if there is risk of low memory...

    For each crash it is good to gather this info:

    • device
    • ios version
    • crash log file
    • how many instances were running ? all of them crashed ?
    • does reloading plugin help ?
    • does NS restart help ?
    • or it is possible to load plugin again only after device restart ?
    • is it crashing always, just occasionary ?
    • what buffer size / sample rate was NS using when it happened ?
    • crashes it also with different buffer size ?
    • how many other plugins or other apos were running ?
    • in ideal case some step by step description how to reproduce crash (although this is not possible often, most of crash events if they are related to memory issues, are random)

    More info we have, better chance to squash bug ;)

    Btw. In my exprience iOS13 helped a LOT in terms of stability compared to iOS12.

  • I’m seeing this with NFM. Oddly NPD doesn’t have the same issue

  • @cianoc said:
    I’m seeing this with NFM. Oddly NPD doesn’t have the same issue

    My experience exactly, just now.

    iPad 2017, iOS13.2.5
    Reloading NFM and restarting NS2 don’t help, but after loading a different plugin in its place and playing it for a while, NFM loads OK again.
    It only happens occasionally.
    44.1khz, buffer high

  • Sometimes i actually see the editor screen for a split second before it switches to the “Loading NFM Editor...” message.

Sign In or Register to comment.