GeoShred Control in NS2 bug: finger release triggers the note

edited November 2022 in Bug Reports

iPad 7th gen
iPadOS 15.7.1
NanoStudio 2 2.1.2
GeoShred Control 5.830.1.8.1

Steps to reproduce:
Open NS2
Create a new project
Add a new Obsidian track
Go to MIDI fx of this track, and connect GeoShred Control
Open GeoShred effect and start playing some notes. At first, everything will be fine
Play long enough until the bug appears (usually takes several minutes)

Expected behavior:
Note is triggered when I put my finger on the screen
Note sustains when I hold my finger on the screen according to the amp envelope
Note decays when I release my finger from the screen according to the amp envelope

Actual behavior:
It takes a few minutes to activate the buggy behavior. Once it does:
Note is NOT triggered when I put my finger on the screen
Nothing happens when I hold my finger
Note is triggered when I release my finger from the screen
Note is sustained forever after until a new note is triggered

Here’s a link with a video recording of the bug. The bug appears at about 1:50.

A link to the NS2 error log I’ve found in settings just in case, even though it seems like it was a different error:

Besides Obsidian, I was able to reproduce the same behavior with AUv3 synths inside NS2.

I have 2 questions:

  • is my workflow correct or should I connect GeoShred Control in a different way?
  • does anyone have the same issue with GeoShred in any other DAW?


  • Hey aoverflow! Interesting situation. Before trying to replicate your situation, I’ll guess it is connected to MPE. Have you tried turing MPE off inside GeoShred Control? I don’t have that app, but I use GeoShred sometimes as an AUv3 instrument. I’ve never noticed a problem using GeoShred’s controller, but I only ever used its controller to play GeoShred presets.
    As far as workflow goes, what works for me is to play a keyboard in NS2 as the controller, but since GeoShred Control is just a controller it seem like you are trying to control Obsidian (or AUv3) with the guitar-like controller. Is that your goal? Is that a more intuitive controller for your background? Or are you trying to get expressive MPE results? Or both?

  • I was able to replicate the problem - sorta - by switching to a different track while holding a note, as well as by switching to a different GeoShred preset while holding a note. I’m starting to think I’m accidentally touching something outside the main GeoShred “fretboard” from time to time, and that prevents GeoShred from generating a noteOff.

    MPE is off. I’ve tried multi channel and single channel. Didn’t notice any difference - both play fine in Obsidian 99% of the time, and both produce the problem from the original post 1% of the time. Probably this 1% is just me accidentally touching something outside the playable UI, that’s the most believable explanation for me so far. So I guess I’ll simply try to be more precise with my finger and palm movements.

    My motivation is not the MPE expressiveness, but rather having an alternative keyboard layout which is more familiar to me due to my guitar background.

    So far the recipe for Obsidian and GeoShred Control seems to be this:

    • play mode string
    • quantization guitar (this way sliding left/right triggers new notes rather than executing pitch bends which are poorly optimized for non-MPE environment)
    • single channel MIDI sounds most logical, but multi channel is probably just fine too
Sign In or Register to comment.